Incorrect display of special characters

  • Author
    Posts
  • #15084
    Victor

    Hello! First of all, please forgive my english.

    Congrats for making such wonderful theme. However, I found a little bug: special characters (like ñ, á, à, etc.) are not displayed ok in the places where fontface is not configurable (slider excerpt, extra text, etc). Seems that you choose a font without special characters, so those are shown without style. Here’s a capture: http://i.imgur.com/vo72q8y.jpg

    I saw that it’s not possible to configure the font of those. How can I change the font to one that shows special chars correctly? Thanks in advance.

    #15114
    LiveKnut

    Hmmm…

    have the same issue. Tried using alternate fonts in the css section but didn’t make it. The text which cannot be changed are Top Title and Second Title in the Extra Text section of PRESENTATION PAGE.

    Yes, your theme is great!

    Would be nice, if you find a solution.
    Regards, LiveKnut

    #15116
    LiveKnut

    I found the issue:
    It is a matter of the international characters within the used font. Although you can change the settings formally in CSS, the font will be overtyped again in style sheet “style-frontpage.css”, see comment /* ISSUE */.

    ########################################
    ### out of style-frontpage.css – BEGIN
    ########################################
    #front-text1 h1, #front-text2 h1{
    /* ISSUE */ font-family: “Open Sans Light”;
    display: block;
    float: none;
    margin: 0px auto;
    text-align: center;
    font-size: 35px;
    line-height: 50px;
    clear: both;
    font-weight: bold; }
    ######################################
    ### out of style-frontpage.css – END
    ######################################

    There is the same issue with the slider titles. It is in style sheet “style.css”, see comment /* ISSUE */.

    ################################
    ### out of style.css – BEGIN
    ################################
    .nivo-caption h2 {
    margin-bottom:10px;
    font-size:24px;
    padding:5px 10px 15px 5px;
    border-bottom:1px solid #444;
    font-weight:normal;
    text-align:right;
    /* ISSUE */ font-family:’Open Sans Light’;
    }
    ################################
    ### out of style.css – END
    ################################

    Would be great, if the developers could fix the configuration plug-in or someone could give me a hint how to fix it without fixing it again and again after reconfiguration Tempera with its configuation tool.

    Happy New Years Eve,
    Knut

    #15118
    LiveKnut

    Now, seems, that I’ve fixed it so far.

    1. style-frontpage.css
    Fix it on the Tempera installation onto the WP server directly. The file is located in the home directory of your WP installation in $HOME/wp-content/themes/tempera/styles/. Comment out the corresponding line.

    2. style.css
    Do the same with this file. It is locate in $HOME/themes/tempera/.

    It seems to be stable also after reconfiguring using the configuration plug-in. Save everything at a good place local on your computer when an update will be installed and you have to do it again…

    Regards,
    Knut

    #15140
    Eva

    Hi
    I have the same problem on the front page. It looks different depending on wich browser your’re using. In Safari the special character appears in bold and in Firefox it is in a different font but only in the title, not the text itself. Hope you can fix this because I’m not up to changing the code yet. (Haven’t done a web site in many years so I’m a little out of practice)
    Happy New Year!
    Best Regards
    Eva

    #15175
    LiveKnut

    Hi Eva,

    Unfortunately I am not the developer. I am user as you are. But it is not very difficult to change. Just just have to go onto the server and change the both particular files exactly at the position I’ve marked above.

    Happy new year!!
    Knut

    #15231
    Victor

    Thank you very much LiveKnut. That worked smooth, all right now. Have a very nice new year!! 🙂

    #15298
    Kay
    Cryout Creations Team

    Hello everybody!

    Thanks a lot for the feedback. The ‘hardcoded’ fonts will be removed in the next theme version and you’ll be able to edit them from the theme settings.

    Thanks again and a Happy New Year to you all!


    Before posting consider reading our short theme debugging instructions.
    Please read the FAQs: MantraNirvanaParabolaTempera
    Tutorials: custom menustranslating themeinstalling themecategory page with introdisabling comments Wordpress: child themescategories/posts
    Before making any modifications to your theme we strongly recommend using Child Themes.
    #15469
    Magnus

    Sounds Great Kay, when will that update be ready? just changed from mantra to Tempera and “found” this problem :/

    #15690
    Zed
    Cryout Creations Team

    Please wait for 0.9.5 which was approved but isn’t yet live.


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Incorrect display of special characters’ is closed to new replies.