Child Theme not working correctly since main theme was upgraded

  • Author
    Posts
  • #39813
    jistwp
    Power User

    I just updated the Tempera theme and now the child theme isn’t working properly. My cryout columns on the presentation page is set up to be two per row and now each one is lining up right under each other…one per row now. If I go back and activate the regular theme the cryout columns go back to the way I designed them. What do I do now?

    #39816

    I also just updated and have an almost identical issue using the Child Theme:
    1. the presentation page Cryout columns align vertically in one column, rather than horizontally in one row.
    2. the Top Text and Second Text font sizes appear reduced.

    However, if I live preview the site using through the main Tempera theme, the font size seems fine, and the Cryout columns do align horizontally. In the preview, however, it only displays Cryout columns 1, 2, & 4 – Column 3 vanishes altogether.

    I also notice a search box in the main navigation bar in both the child and main theme, but cannot see how to disable/otherwise manipulate it.

    Infidelity Help Group

    (As an aside: I haven’t been to the site or the forums for a while, but I’m loving the new look!)

    #39824

    I have the same problem reported by Wayfarer – when updating Tempera from 1.4.6 to 1.4.7 the Cryout Column items all appear in a single column at reduced size instead of three columns and the More buttons are completely messed up.

    The site is our test site at rgneighbours.elementfx.com/rva-test1/ and I’ve had to go back to an older version of the theme. Here are a couple of screenshots, one showing the home page appearance after the theme update from 1.4.6 to 1.4.7 and the other showing what happens when I hover the mouse over an image in the column.

    Image 1: http://rgneighbours.elementfx.com/rva-test1/wp-content/themes/tempera-child/screenshot1.png

    Image 1: http://rgneighbours.elementfx.com/rva-test1/wp-content/themes/tempera-child/screenshot2.png

    #39828
    Kay
    Cryout Creations mastermind

    Hi guys,

    Some CSS got moved around in this latest update. Make sure you force refresh the site (Ctrl + F5) and check again.

    Also, search bars have been added to all the menus, and the top menu and main menu are active by default. You can disable them from the Graphics section.


    @wayfarer
    Welcome back, we missed you too 😀


    Before posting consider reading our short theme debugging instructions.
    Please read the FAQs: MantraNirvanaParabolaTempera
    Tutorials: custom menustranslating themeinstalling themecategory page with introdisabling comments Wordpress: child themescategories/posts
    Before making any modifications to your theme we strongly recommend using Child Themes.
    #39832

    Unfortunately it’s still he same for me even after clearing the browser cache as well. Perhaps you could try the site yourself – it is at http://rgneighbours.elementfx.com/rva-test1/

    We do use a lot of custom CSS, so I think something in the new theme CSS is conflicting with ours.

    TIA!

    David.

    #39835
    jistwp
    Power User
    This reply is private.
    #39837

    I’ve done a comparison wit our live site, and it looks like the front page CSS code that was in the file style_frontpage.css isn’t being picked up. If I add this CSS manually bit by bit things start to look better. Could you please let me know where this CSS has been moved to – is it a new file that my child theme CSS isn’t aware of?

    Many thanks,

    David.

    #39838
    Kay
    Cryout Creations mastermind

    @dneale123 You’re not doing the whole child theme thing properly. The child theme’s CSS shouldn’t also contain the parent theme’s old CSS. You are not including Tempera’s styling (which in the last version changed quite a bit, as it always does) and you’re using old Tempera styling (from version 0.9.8?). You need to only leave your Custom CSS in there and include the parent theme’s CSS via @include (which you commented out).

    And yes, style-frontpage.css has been moved inside the main style (style.css). If you just want to copy that code into your child theme’s stylesheet (which is something I strongly advise against) you’d have to copy the section in style.css from /* Presentation Page */ up until /* Style HTML5 tags for IE8 and lower */ .

    Again, you’re doing things wrong and further updates will probably cause other issues. The reason child themes exist is so that you can update the parent themes without having to worry about code changes. Keeping an old version of the style in your child theme and not using the current theme’s stylesheet is a bad practice and kind of renders null the use of a child theme.


    @jistwp
    Could you show us a link to your site?

    • This reply was modified 5 years ago by Kay.

    Before posting consider reading our short theme debugging instructions.
    Please read the FAQs: MantraNirvanaParabolaTempera
    Tutorials: custom menustranslating themeinstalling themecategory page with introdisabling comments Wordpress: child themescategories/posts
    Before making any modifications to your theme we strongly recommend using Child Themes.
    #39840

    @Kay: Thanks, our site was set up more than 2 years ago in the days before the @import method was deprecated and I’d forgotten we’d hardcoded the Tempera CSS into our child theme (originally done to improve performance)! So 2 years of updates worked by chance 🙂 Have re-created the child theme style.css to bring in the parent theme style.css and it’s OK now.

    #39841

    Update: The issue self-corrected for me when I checked the site this morning, without even having to force refresh.


    @Kay
    Thank you for the help with the search bar – I couldn’t see the option, and blame either a lack of coffee, or a brain fart. Or both. 😀

    #39856
    jistwp
    Power User

    Here is the link to the site I’m working on. As I said, I have used this theme over and over again so I hope it is a simple fix.

    http://pcdoctorllc.net/

    • This reply was modified 5 years ago by jistwp.
    #39858
    Kay
    Cryout Creations mastermind

    Could you activate the child theme as well so we can see the issue? Everything is looking fine right now.


    Before posting consider reading our short theme debugging instructions.
    Please read the FAQs: MantraNirvanaParabolaTempera
    Tutorials: custom menustranslating themeinstalling themecategory page with introdisabling comments Wordpress: child themescategories/posts
    Before making any modifications to your theme we strongly recommend using Child Themes.
    #39859
    jistwp
    Power User

    Yes… take a look now. I just activated the child theme. The copyright link is gone but the presentation page is a mess.

    #39860
    Kay
    Cryout Creations mastermind

    The presentation page (and everything else) looks the same. Did you force refresh (Ctrl + F5) the page?


    Before posting consider reading our short theme debugging instructions.
    Please read the FAQs: MantraNirvanaParabolaTempera
    Tutorials: custom menustranslating themeinstalling themecategory page with introdisabling comments Wordpress: child themescategories/posts
    Before making any modifications to your theme we strongly recommend using Child Themes.
    #39862
    jistwp
    Power User

    Try it now.

    #39864
    Kay
    Cryout Creations mastermind

    Yes, it’s still the same. You’re not telling me if you did a successful force refresh. Did you try it on another browser as well?


    Before posting consider reading our short theme debugging instructions.
    Please read the FAQs: MantraNirvanaParabolaTempera
    Tutorials: custom menustranslating themeinstalling themecategory page with introdisabling comments Wordpress: child themescategories/posts
    Before making any modifications to your theme we strongly recommend using Child Themes.
    #39865
    jistwp
    Power User

    Yes I did a CNTL F5 and it still looks the same on Google Chrome. However it looks fine on Microsoft Edge. Could it be the fact that I’m using Windows 10 on Google Chrome to view it?

    #39867
    Kay
    Cryout Creations mastermind

    It looks the same on all browsers, you’re just seeing it different because of a caching matter. http://www.refreshyourcache.com/en/home/ this is a link on how to do clear your cache.


    Before posting consider reading our short theme debugging instructions.
    Please read the FAQs: MantraNirvanaParabolaTempera
    Tutorials: custom menustranslating themeinstalling themecategory page with introdisabling comments Wordpress: child themescategories/posts
    Before making any modifications to your theme we strongly recommend using Child Themes.
    #39871
    jistwp
    Power User

    OK. I followed the instructions and it looks fine on Google now. Thank You!

Viewing 19 posts - 1 through 19 (of 19 total)

The topic ‘Child Theme not working correctly since main theme was upgraded’ is closed to new replies.