Reset theme settings “Do not display again” doesn’t work

  • Author
    Posts
  • #99235

    On all my admin pages I get the following warning:

    View post on imgur.com

    When I click on “Do not display again”, I get sent to the theme page, but the issue isn’t resolved. As soon as I go to another admin page (like posts, or media, etc) I get the above warning again.

    If I completely reset the theme settings, the message disappears, but I lose all customization. As soon as I again set some customization, that message then appears again.

    Is there a way to make that message disappear permanently? Ideally without having to reset my settings?

    #99388
    Zed
    Cryout Creations Team

    That happens due to leftover debugging code resetting the ‘do not remind’ state (which we’ll correct in the next child theme update).
    Edit the child theme’s includes/notices.php file and comment out or remove the following line:
    set_theme_mod( 'liquido_configured', FALSE ); // TEEEEEEEMMMMMPPP!!!!!
    Then use the ‘hide’ button once more.


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
    #107308

    Just a head’s-up, this is still an issue.

    I notice in my theme’s includes/notices.php file, that the following line HAS been commented out:

    // set_theme_mod( 'verdant_configured', FALSE ); // dev mode

    But this does not seem to be enough. I had to un-comment the line, and EXPLICITLY set the value to TRUE rather than FALSE. It doesn’t seem to default appropriately with the line removed.

    Thanks!

    Website: steveperkins.com

    #107388
    Zed
    Cryout Creations Team

    Hi Steve,

    That line is a dev line intended to be used to force the nag theme mod to a specific value.
    Having it commented out (with either value) is the normal state as the theme mod is handled by other code.

    If you are still running WordPress 5.5 on the site try updating to 5.5.1 and check if the nag disable link still fails to work – with that line of code in its default state (as there were some dashboard nonce checking issues in 5.5).


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
Viewing 4 posts - 1 through 4 (of 4 total)

You need to log in to reply to this topic.