Remove blog posts from homepage?

  • Author
  • #50422

    Hi, on the homepage, there are 3 blog posts listed. Is there a way to remove this? Under Customize–>Post information–>Excerpts, there’s a choice to post excerpts or full posts on the homepage, but I don’t see a way to disable posting on the homepage. This theme has so much great customization and I can remove other things from the homepage, so I’m hoping I can remove this too. If not, can you recommend a similar theme you have that doesn’t show blog posts on the homepage? Thanks.

    Cryout Creations mastermind

    You can disable the landing page posts list (or static page) from the theme’s Landing Page > General options section.

    The Post Iinformation options control how posts are displayed throughout the site, not just the landing page.

    If you like our creations, help us share by rating them on
    Please check the available documentation and search the forums before starting a topic.

    There is no “General options” under Landing Page. There’s Landing Page->Settings where I can change the featured post to “disabled”, but the blog posts are still showing up. The option I had before was “static page.” I see a “posts” option, which will show the posts below the 3 boxes of excerpts–so they show up twice. But nothing is making the 3 boxes go away.

    I’ve disabled every area on the homepage. But I still have those 3 blog post boxes below the slider.


    Found it! Landing page->Featured Box Top: Set “boxes content” to DISABLED.


    Oops, you have to do the same thing for Featured Box Bottom.


    When I set Landing Page > Settings > Landing Page = Enabled for Septera I end up seeing full content of Pages on the Homepage as well, interleaved with the boxes with a gray background. I then see the same content below the boxes against the white background. So Pages are appearing unexpectedly twice.

    In my case I have Pages without Parents (which default to Main Page as a result) as I’m using them to build out the Masthead navigation. I will play around with this some more but it was a bit unexpected and probably the biggest struggle I’ve had so far as a first-time user aside from setting Header images.

    Nevertheless, wonderful theme and still 5 stars in my book.

    PHP 7, WP 4.8, Pantheon



    Try going to Landing Page, and then with each option (Featured Icon Blocks, Featured Boxes Top, Featured Boxes Bottom, Text Areas) disabling everything. Then add back one at at time to see what goes where. Right now I have everything disabled except Text Areas–>Text Area 1, which I have set to “Home” so the information I have on the page named “home” shows up there. You can have other pages show up as well if you want. Disable them all to start and the add back in what you want.


    @cgs18 That’s good advice. After disabling each option I can see the boxes and other items have disappeared but the pages without parents remain (with a grey background), as well as the sample page (with a white background). I then went to WP Settings > Reading and disabled the Sample Page front page and that removes the Pages I didn’t expect to see output. Not exactly what I wanted but certainly helps isolate what’s happening. Thank you.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Remove blog posts from homepage?’ is closed to new replies.