Latin Extended font problem

  • Author
  • #14913
    Zoltan Barabas


    I’VE just discovered Tempera, and it seems the best free WP theme out there! At first glance my only but serious problem is that Latin Extended characters don’t display correctly. What can cause this? Thank you for your help!


    Cryout Creations mastermind

    It’s most likely a font, browser or OS limitation. If other international sites look fine, try changing to a different font. Not all the fonts we included have characters beyond the most basic set.

    If you like our creations, help us share by rating them on
    Please check the available documentation and search the forums before starting a topic.

    Hi, thanks for your reply. I set OpenSans that should contain latinext characters, but I experience very strange results. In Chrome the site title displays correctly, but in other texts, those characters are substituted with TimesNewRoman. In IE and FF all texts are displayed badly.
    FF shows the site is UTF-8, so it should be all right. Any idea?

    Thank you



    I’ve got exactly the same problem with Tempera theme and Open Sans font.

    Strangely enough, diacritic marks display fine when I’m logged into my WP admin panel, but they’re substituted with Times New Roman font when I’m logged out and visit my website. The website will be published in Polish and I work on it in Chrome.

    Dear Support Team, if you could tell us which of fonts included in this theme should be fine with Latin Extended characters set, I would be more than grateful (and I think Zoltan too)!

    Looking forward to your reply.
    Thanks in advance!



    Just a little update from me. I have finally used Calibri font instead of Open Sans for the main text and Impact font in headers. The effect is not exactly what I wanted to achieve, but at least it looks fine and, what is even more important, the Polish diacritic marks display OK in Chrome. All in all, it is acceptable for me for the time being as I have to move on with my website and publish it soon.

    Zoltan, perhaps it is worth trying to set a different font, just like Zed suggested. I know that the visual effect may not be perfect but I think you can still try to solve this issue on a later stage and set a different font for now. Such a small imperfection should not impede the workflow I think. It is always better to get things done than to be stuck with small-but-annoying issues that appear on the way. They will always do 😉

    Good luck and all the best in your business!

    Zoltan Barabas

    Hi Iwona,

    thanks for your advice, I tried Calibri, set it everywhere on text settings, still on some places Open Sans is stucked in somehow 🙁 I don’t know how to get rid of it.
    I’d like to find a solution, because this is a really nice theme. Some other themes I use also have this problem, but I use many that haven’t. I’d like to understand the logic behind this kind of problem that occurs time to time. I’m haunting usable themes to review them to the Hungarian WP users and I’d like this one to be among them.

    Best wishes!

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Latin Extended font problem’ is closed to new replies.