Fatal error: Uncaught Error: Call to a member function is_block_editor() on null

  • Author
    Posts
  • #130245

    Hi there,

    I’ve been getting this in my error log a few times per week since I updated my site to WordPress 6.0. Any chance it’s related to the theme? 7 looks a bit odd, but that is pasted properly from the log.

    I have not yet had the site not load for me and have not seen this error “live”, some of the occurences are at thee o’clock in the morning when I’m pretty sure few people are checking out a school homepage…

    Any help is appreciated, including a “that’s not us” 😉

    Fatal error: Uncaught Error: Call to a member function is_block_editor() on null in /homepages/30/d606011685/htdocs/wwwroot/wfs-dreieich.de/wp-includes/script-loader.php:2407

    Stack Trace
    1.
    wp_global_styles_render_svg_filters(”)
    /homepages/30/d606011685/htdocs/wwwroot/wfs-dreieich.de/wp-includes/class-wp-hook.php:307
    2.
    WP_Hook->apply_filters(NULL, Array)
    /homepages/30/d606011685/htdocs/wwwroot/wfs-dreieich.de/wp-includes/class-wp-hook.php:331
    3.
    WP_Hook->do_action(Array)
    /homepages/30/d606011685/htdocs/wwwroot/wfs-dreieich.de/wp-includes/plugin.php:476
    4.
    do_action(‘wp_body_open’)
    /homepages/30/d606011685/htdocs/wwwroot/wfs-dreieich.de/wp-content/themes/parabola/includes/theme-functions.php:556
    5.
    parabola_wp_body_open(”)
    /homepages/30/d606011685/htdocs/wwwroot/wfs-dreieich.de/wp-includes/class-wp-hook.php:307
    6.
    WP_Hook->apply_filters(”, Array)
    /homepages/30/d606011685/htdocs/wwwroot/wfs-dreieich.de/wp-includes/class-wp-hook.php:331
    7.
    /homepages/30/d606011685/htdocs/wwwroot/wfs-dreieich.de/wp-includes/p in /homepages/30/d606011685/htdocs/wwwroot/wfs-dreieich.de/wp-includes/script-loader.php on line 2407

    Website: www.wfs-dreieich.de

    #130569
    Zed
    Cryout Creations mastermind

    Hi,

    The do_action('wp_body_open') call that’s part of the theme’s code and referenced in the error trace is a core WordPress hook introduced in version 5.2. This hook allows plugins to add their own functionality in a specific markup location (the opening of the <body> tag).

    My guess is that a plugin is adding its functionality to this hook but fails to work properly, throwing the error. I suggest to temporarily disable all active plugins and to check if the error logging goes away, then re-activate the plugins one by one until the error returns. That should point out which plugin the problem is related to.


    If you like our creations, help us share by rating them on WordPress.org.
    Please check the available documentation and search the forums before starting a topic.
Viewing 2 posts - 1 through 2 (of 2 total)

You need to log in to reply to this topic.