Error message after Debian 12 upgrade

  • Author
  • #140454

    Dear Cryout Staff!

    Two days ago I updated our school’s server to Debian 12. After that WordPress is displaying a Fatal Error message. I enabled debug, deleted cache(simple-cache plugin), disabled plugins. Installed PHP 8.1 because 8.2 is unsupported in wordpress and Nextcloud.
    But now I’m clueless.
    This is the error message:
    “[15-Jul-2023 10:04:06 UTC] PHP Fatal error: Uncaught ValueError: Unknown format specifier ” ” in /var/www/html/wp-content/themes/tempera/includes/theme-setup.php:284
    Stack trace:
    #0 /var/www/html/wp-content/themes/tempera/includes/theme-setup.php(284): sprintf()
    #1 /var/www/html/wp-includes/class-wp-hook.php(308): tempera_widgets_init()
    #2 /var/www/html/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters()
    #3 /var/www/html/wp-includes/plugin.php(517): WP_Hook->do_action()
    #4 /var/www/html/wp-includes/widgets.php(1854): do_action()
    #5 /var/www/html/wp-includes/class-wp-hook.php(308): wp_widgets_init()
    #6 /var/www/html/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters()
    #7 /var/www/html/wp-includes/plugin.php(517): WP_Hook->do_action()
    #8 /var/www/html/wp-settings.php(617): do_action()
    #9 /var/www/html/wp-config.php(73): require_once(‘…’)
    #10 /var/www/html/wp-load.php(50): require_once(‘…’)
    #11 /var/www/html/wp-blog-header.php(13): require_once(‘…’)
    #12 /var/www/html/index.php(17): require(‘…’)
    #13 {main}
    thrown in /var/www/html/wp-content/themes/tempera/includes/theme-setup.php on line 284″

    All help is greatly appreciated. I hope I wont’t have to go back to PHP 7.4 to fix this. Because then I will be stuck there. Nextcloud won’t update on PHP7. Maybe PHP 8.0?

    Sincerely: Gyula Szilagyi



    This is line 284:
    ‘description’ => sprintf(__(‘Only drag [Cryout Column] widgets here. Recommended size for uploaded images: %1$dpx (width) x %2$dpx (height). Go to the Tempera Settings page >> Presentation Page Settings >> Columns to edit sizes and more.’,’tempera’ ), $temperas[‘tempera_colimagewidth’],$temperas[‘tempera_colimageheight’]),

    A friend of mine tried Tempera in a test WP server. He cannot activate the theme, same error(PHP 8.1 and apache).
    So it is a compatibility issue after all?
    Please help, this is a school’s homepage, the will need it in august.
    Or is there a way to migrate a newer theme of yours?


    A friend discovered that there is a bug in the theme’s translation files. A value is not accepted (% 1 $ dpx). PHP 7.4 still forgave the error, but 8.1 no longer allowed it in our opinion. He recompiled the .mo and .po files and I overwrote the existing ones.
    So the theme really works on PHP 8.1 as well.

Viewing 3 posts - 1 through 3 (of 3 total)

You need to log in to reply to this topic.