502 Bad Gateway error

  • Author
    Posts
  • #122454

    Hello,

    My name is Cristi and I have an issue with my website canticer.bio

    The website is hosted on wordpress.com and for few weeks I faced this error when I try to access my website https://drive.google.com/uc?id=1LwsisiREqbY4TI-_r84INUda2JnSfwkP

    There are moments when the websites loads but then after you few minutes, it’s down again.

    I contacted the wordpress.com support team and they manage to replicate the error and find this error in the CLI.

    [12-Oct-2021 20:31:43 UTC] PHP Notice: Undefined index: WP_Widget_Recent_Comments in /srv/htdocs/wp-content/themes/nirvana/includes/theme-comments.php on line 74
    [12-Oct-2021 20:31:44 UTC] PHP Notice: Undefined index: WP_Widget_Recent_Comments in /srv/htdocs/wp-content/themes/nirvana/includes/theme-comments.php on line 74
    [12-Oct-2021 20:31:44 UTC] PHP Notice: Undefined index: WP_Widget_Recent_Comments in /srv/htdocs/wp-content/themes/nirvana/includes/theme-comments.php on line 74
    [12-Oct-2021 20:31:44 UTC] PHP Notice: Undefined index: WP_Widget_Recent_Comments in /srv/htdocs/wp-content/themes/nirvana/includes/theme-comments.php on line 74

    The error appeared to them at the 3rd chat talk with them in 3 weeks. For the first two chats, they didn’t manage to replicate the error, for them the website was working. But for me, it was down for weeks. I ve tested the website from multiple devices and IP addresses from Romania and had the same issue.

    They recommend to activate another theme to see if the error persist and after I activated another theme, the website is working fine.

    Can you help us please to solve this issue because we want to continue to use your website.

    I reactivated the theme so you can take a look.

    Thank you very much.

    Wish you a great day,
    Cristi

    Website: canticer.bio

    #123398
    Zed
    Cryout Creations mastermind

    Hi,

    That bit of code attempts to remove WordPress’ built-in styling applied to the recent posts widget. Perhaps the system the theme is running on does not have this functionality, making the function call fail.

    If you have access to the theme’s files or are able to install the theme as zip on that system, edit the indicated nirvana/includes/theme-comments.php file and comment out (or delete)
    add_action( 'widgets_init', 'nirvana_remove_recent_comments_style' );
    on line 76 below to disable that part of code.

    Please let us know if that works and we’ll include an additional check in the next update to avoid this in the future.


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
Viewing 2 posts - 1 through 2 (of 2 total)

You need to log in to reply to this topic.