Specific Header image for each page

  • Author
  • #55049

    Power User

    I’m really loving this theme. Best one so far.

    Can anyone tell me how to create a different header image for each page/post.
    Also on some pages, i don’t want a header image. Is this possible?


    Website: elitedjsperth.com


    Cryout Creations Team

    The theme has an option (under the Featured Image options) to use page/post featured images as header image (if they are large enough).

    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.


    I have the same problem. Can I only use ONE image for all pages and posts in the header? How can I use different headers and how can I connect those to specific pages?



    Power User

    Hey Linda,

    You need to remove the header image in the header media under site identity.

    then you should be able to use the default wordpress page featured image



    I have custom header images using the featured header image for each page and making sure the images are about 1850 wide by whatever high I needed. I have a header image on my Landing Page using the Customizer Landing Page Slider set to static image.


    Cryout Creations Team

    When the theme’s Featured images in the header option is enabled in the options, the theme will display the posts’ / pages’ featured images in the header (even instead of the site-wide header image) if the featured images are large enough (at least 75% of the configured site width and image header height).

    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.

    1. I have removed the header image under site identity,
    2. I have gone to “Pages” -> “About Us” and uploaded a featured image at 1920px wide
    3. I have gone to post information and enabled used featured image
    4. Still no image showing up

    Check it out here you can see there is no image behind the About Us text

    About Us

    Any help would be great. Thanks.

    Website: www.tpichemcial.capitallaunchstudio.com/welcome


    If your image is not large enough it will not show up. Check your image sizing again. I had one image that just wouldn’t show. In Media it showed the size as 1850×919. I downloaded it, opened in my image program and it was only 1080x4xx! I had to go back and resize and upload. Then it worked.


    Is there any way to keep the option to use featured image as header image in general for all posts/pages, and disable this option for a few specific posts/pages?


    What worked for me: I created a header image that isn’t large enough for the pages I wanted no image to show. That will cause the default images you have selected in the Custom Header to take over. If you don’t have anything set in the Custom Header then you won’t have a header image.


    Thank you. This is indeed the solution that I have used now. It is not fully robust because in my case there are several users-editors that can edit the website, and some users will probably upload larger images in the future for a page/post that should not use the header image. A per-post/page option would have been much easier, but the workaround is working for now.

Viewing 11 posts - 1 through 11 (of 11 total)

You need to log in to reply to this topic.