Hamburger Menu not working on mobile

  • Author
    Posts
  • #106225

    Hi, first of all Thanks a lot for the wonderful theme! I love all the functions and it’s great to find a theme that allows so many adjustments.

    But I’m having a problem with the theme on my Android mobile phone. The hamburger menu is displayed, but I can’t click on it. Or rather, when I click on it, nothing happens. The menu doesn’t show. I tried loading some other templates like Nirvana and Septera, but I’m getting the exact same issue on mobile, menu isn’t working.

    Any idea what might be causing this issue?

    Thanks in advance for your reply.
    Erika

    Website: www.wetpics.nl

    #106226

    After posting my question I continued searching for an answer and I read somewhere that this might be caused by a plugin. I de-activated W3-Total Cache and now it’s working perfectly!

    I hope this may help someone else who might be experiencing the same issue 🙂

    #106299
    Zed
    Cryout Creations Team

    You probably had CSS minifying enabled in the caching plugin. Tempera needs its styling to be applied in a particular order for it to work correctly and minifying usually breaks this order.
    You should be able to reactivate caching if you exclude the theme’s styles from minification or do not use this functionality.


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
    #106576

    I’m having this same issue, but even after deactivating my Cache plug-in (WP-Optimize), the Hamburger Button still will not work. Along with this, side widgets that had video on them suddenly either showed the video full size (thus sending it off the page and past the widget square), or showed a blank video player. I removed them for now, but the hamburger button is most important.

    This all seemed to have happened after WordPress 5.5 for me, so I’m wondering if that’s related. Any idea for a work around? I did note before deactivating WP_Optimize that it did not have Mini-ing turned on.

    Thanks for all your help!
    Jason
    game-rave.com

    #106895
    tomppa28
    Power User

    Hello all! I had the same problem, and it is definitely linked to WP 5.5. I could restore menus by deactivation “Optimize Javascript” in Autoptimize, but I had this feature enabled for a long time without any problem.

    Website: baugelitt.eu

    #106921
    Zed
    Cryout Creations Team

    @StudioDangerboy: how are the videos embedded (which shortcode/widget/block)?


    @tomppa28
    : JS optimization shouldn’t cause issues, it’s only the CSS that needs to be applied in the correct order (and optimizations sometimes mess with the order). But that really depends on what the plugin is actually doing under the hood.


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
    #107066

    Hey Zed,

    I use “Embed Plus for YouTube – Gallery, Channel, Playlist, Live Stream” plug-in. However in checking it, I noticed something else when *not* using it.

    I could have sworn if you pasted a YouTube url right into the post – no plugin or embed code, it auto-generated the video embed and you could see the video right in the compose window. Now it doesn’t do that. Found that odd.

    Thanks!
    Jason

    #107112
    Zed
    Cryout Creations Team

    Direct embeds have always been a core WordPress feature: https://wordpress.org/support/article/embeds/

    If these no longer work for you, then something may be affecting or disabling this.


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
    #107684

    Wordpress 5.5+ also caused problems with the hamburger menu on our site.

    The plugin Enable jQuery Migrate Helper corrected the issue for us.

    Thanks for the use of Tempera on our nonprofit organization’s website!

    Website: www.pawsmontclair.org

    • This reply was modified 7 months ago by NEMaudio.
    #109853

    Hi
    I have a similar problem on an iPhone. The website works everywhere else but on an iPhone the hamburger menu does nothing.
    Any suggestions?

    Website: Www.gamlingayhistory.co.uk

Viewing 10 posts - 1 through 10 (of 10 total)

You need to log in to reply to this topic.