Impossible to have mailpoet subscribe newsletter checkbox on comments

  • Author
    Posts
  • #63752

    Hi,

    I’m using Mailpoet 3 to manage newsletters.
    I enabled an option, normally working fine, to have a checkbox on the comments for visitors to subscribe newsletter.
    Unfortunately, with Fluida, this checkbox doesn’t appeared…

    Can you help on this ? Do you have any suggestion ?

    Thanks a lot,

    Website: www.dumondedanslobjectif.com

    #63753

    Huummmm… I see this additional code :

    <p class=”comment-form-mailpoet”>
    <label for=”mailpoet_subscribe_on_comment”>
    <input type=”checkbox” id=”mailpoet_subscribe_on_comment” value=”1″ name=”mailpoet[subscribe_on_comment]”> Oui, ajoutez-moi à votre liste de diffusion.
    </label>
    </p>

    The label tag seems wrong. I think it’s a problem from mailpoet editor.

    I didn’t manage to delete or close this post. Can you do it ?

    Sorry for this topic

    #63908

    Zed
    Cryout Creations Team

    There doesn’t seems to be anything wrong with that code.
    Switch the theme’s option to use form labels instead of placeholders if you’re adding extra fields to the comment form.


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
    #64547

    Thank you for this advice, I forget to use this field, now it works fine !!! 😀

    Website: www.dumondedanslobjectif.com

    #64797

    Zed
    Cryout Creations Team

    In the recent 1.5.5 update the plugin’s checkbox should be correctly displayed even when using the theme’s “placeholders” option.


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Impossible to have mailpoet subscribe newsletter checkbox on comments’ is closed to new replies.