How to set a Separate Page for Blog Posts in Septera

  • Author
    Posts
  • #42821

    How can i config a page for blog posts?

    Thanks for your help.

    btw: I love the design of the new septera-template!

    #42986
    Zed
    Cryout Creations Team

    This is possible if you use WordPress’ functionality (Settings > Reading) to assign a static page on the homepage (as part of the landing page) and then a separate blog page.


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
    #43075

    Hi there. I also have the same question. In the reading section, I have my homepage set as a static page, and I have set a separate page (Blog) as my posts page, but for some reason the posts are not appearing on that page. Did I miss something?

    Website: www.horizonstudy.com

    #43179
    Zed
    Cryout Creations Team

    The ‘Blog’ section appears to work now, as it displays 3 posts.


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
    #43533

    I did this, but all my landing page information (slider static image, featured blocks) disappears. It looks just like my blog page (which does work when I do this).

    #43683
    Zed
    Cryout Creations Team

    @mikah257, check if the static page you’re setting as the homepage has a template assigned. If it does, the landing page will be disabled and only the static page content will be displayed.

    Edit: This is no longer the case in Septera.


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
    #43698

    OK… I created a new page which I gave the title ‘home,’ but made no other changes, and one called blog, with no other changes. The blog page works fine, but the home page does not have my landing page items. It does certainly seem to have a template set, but I do not know how to create a page without the template. In FAQs, I see that some themes have a setting in Page Attributes called ‘Templates.’ I don’t have that–mine only has ‘Parent’ and ‘order.’ Is template set elsewhere in this theme, or is this setting available only in a paid version?

    Website: www.writingdreamer.com

    #43856
    Zed
    Cryout Creations Team

    I’m sorry, my previous answer wasn’t entirely accurate as it applies to Fluida.

    In Septera activating a static page on the homepage also activates the landing page feature (we were asked to implement this change during the theme repository review process).


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
    #44229

    Hi,

    I also have the same issue, and would like to present the landing page feature while having a separate page for posts. What Zed last said seemed to imply that it was impossible. As of now, is there a way to do that yet? Thank you!

    #44490
    Zed
    Cryout Creations Team

    @elemdark, if you update to 0.9.4/0.9.5 you will *need* to assign a static page on the homepage for the theme’s landing page to become active, and this will also allow you to set a blog page.


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
    #44509

    thank you!

    well, when I implemented this, all of my jetpack related stuff went nuts. if I turn off jet pack, the blog page looks ok, but all my other generated pages stop working. turn it on, and I get the missing argument. jetpack up to date, septera now on 9.5.

    Website: writingdreamer.com/blog

    • This reply was modified 3 years ago by mikah257.
    #44779
    Zed
    Cryout Creations Team

    @mikah257, there may be a conflict between Jetpack’s Photon service and our theme’s latest srcset support improvements. We are looking into this, in the meantime try to disable the Photon functionality and see if that solves anything.


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
    #44806

    I updated to Jetpack 4.9 before trying your suggestion, which did not help. However, turning off Photon DID solve the problem.

    Website: www.writingdreamer.com

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘How to set a Separate Page for Blog Posts in Septera’ is closed to new replies.