Featured Images Won't Display In Headers

  • Author
    Posts
  • #54319

    fusionaddict
    Participant

    I have the option turned on to display featured images for pages and posts in the headers, but it isn’t working. I have confirmed the option is enabled and I have tried regenerating the thumbnails. The size of the images isn’t the issue because all my featured images are larger than the display area. Please advise.

    Website: www.scarleteye.net/mbaa

    #54412

    zed
    Keymaster

    The featured images need to be large enough (at least 75%) of the configured site width to be used in the header.


    If you like our creations, please rate them on WordPress.org.
    #54434

    fusionaddict
    Participant

    Let me try this again.

    The size of the images isn’t the issue because all my featured images are larger than the display area.

    My site is set for a max width of 1920, and all my image widths are larger than that.

    #55460

    laiello
    Participant

    I am having the same issue – in fact, I don’t see any type of option with the featured image to make it the header image as well. Theme docs are seem to be being worked on so I can’t really look it up

    Website: www.layloyoga.com

    #55571

    zed
    Keymaster

    @laiello, it’s the last option under the theme’s Featured Image options. Note that the feature does not apply to the homepage when the theme’s landing page is used.


    If you like our creations, please rate them on WordPress.org.
    #55588

    laiello
    Participant

    The only place I see featured image options is for posts, but not for pages. In fact, I don’t see a way to really alter anything about pages.

    Website: www.layloyoga.com

    #55624

    zed
    Keymaster

    Both posts and pages support the same featured images functionality in WordPress.


    If you like our creations, please rate them on WordPress.org.
    #57055

    utpal
    Participant

    I have enabled ‘Customizing>Post Information>Featured Image>Featured Images in Header’ option
    The images were as wide as the page and yet one image was not showing up.
    The write-up for the page was only 2 or 3 lines.
    When I added more words to the page, the featured image showed up.
    Maybe this could work for others.

    • This reply was modified 1 week, 1 day ago by  utpal.
    #57147

    laiello
    Participant

    @fusionaddict – I didn’t do anything special, honestly to start getting it to work. It just started working.

    In the dashboard:
    Appearance
    Customize
    Post Information
    Featured Image
    Scroll to the bottom of the options where it says “Use featured image in header” and select enable
    I did log out and log back in (to reset a different issue) and then it began working for pages as well as posts. I wish I had a special trick to share. It was just one of those things….

Viewing 9 posts - 1 through 9 (of 9 total)

You need to log in to reply to this topic.