Featured image displayed

  • Author
    Posts
  • #67067

    Hello! I’ve read a few posts on this topic but haven’t seen an answer.

    I set featured images for some posts, have regenerated the thumbnails, and still the “contained” setting for featured images provides a rather unfortunate narrow cropping of my image. I tried changing it to the “cropped” setting instead of “contained” but that was even worse because my images are rather large (I like the high resolution). Any suggestions?

    Website: brainfuelness.com

    #67282

    Zed
    Cryout Creations Team

    It really depends on the images. The theme will try to generate crops at the appropriate size (configured height and calculated width – dependent on site width and posts columns count). The cropping position is also configurable (to try to position the viewpoint on the more relevant part of the images)

    If you are not satisfied with how the crops turn out, you can disable cropping entirely by setting the featured image height to 0. This will make the theme display the images as they are (only shrinking them to fit the width).


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
    #67287

    Thank you for your answer. What I would like to do is achieve what you described in the second part of your comment. But when I try what you suggest no images are displayed at all. How can I set that parameter to 0 and still see pictures?

    Thanks a lot for the help

    #67493

    Zed
    Cryout Creations Team

    Make sure you clear the cache after changing the value to 0 (as some generated styling is updated by this change).


    If you like our creations, help us share by rating them on WordPress.org.
    Please read the available documentation and search the forums before posting.
    #67501

    Thank you for your answer.

    I cleared the cache in my browser and in wordpress (I’m using the WP Fastest Cache plug in) and it doesn’t change anything.

    I went back to the image editing and when I edit the image it clearly shows me that the thumbnail is the complete image but it doesn’t show up on my website.

    #67728

    I think I figured it out. I think that your technique did work, it’s just that some of my images weren’t wide enough initially so the theme is cropping them at the top instead of making it wider to fit the complete image in the thumbnail. Is that a possibility or am I completely off?

    Thanks a lot for your help.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Featured image displayed’ is closed to new replies.